201604-4 游戏

问题描述   

小明在玩一个电脑游戏,游戏在一个n×m的方格图上进行,小明控制的角色开始的时候站在第一行第一列,目标是前往第n行第m列。

方格图上有一些方格是始终安全的,有一些在一段时间是危险的,如果小明控制的角色到达一个方格的时候方格是危险的,则小明输掉了游戏,如果小明的角色到达了第n行第m列,则小明过关。第一行第一列和第n行第m列永远都是安全的。
 
每个单位时间,小明的角色必须向上下左右四个方向相邻的方格中的一个移动一格。

经过很多次尝试,小明掌握了方格图的安全和危险的规律:每一个方格出现危险的时间一定是连续的。并且,小明还掌握了每个方格在哪段时间是危险的。  

现在,小明想知道,自己最快经过几个时间单位可以达到第n行第m列过关。
输入格式
 
输入的第一行包含三个整数n, m, t,用一个空格分隔,表示方格图的行数n、列数m,以及方格图中有危险的方格数量。
 
接下来t行,每行4个整数r, c, a, b,表示第r行第c列的方格在第a个时刻到第b个时刻之间是危险的,包括a和b。游戏开始时的时刻为0。输入数据保证r和c不同时为1,而且当r为n时c不为m。一个方格只有一段时间是危险的(或者说不会出现两行拥有相同的r和c)。

输出格式
 
输出一个整数,表示小明最快经过几个时间单位可以过关。输入数据保证小明一定可以过关。

样例输入

3 3 3

2 1 1 1

1 3 2 10

2 2 2 10

样例输出

6

样例说明

第2行第1列时刻1是危险的,因此第一步必须走到第1行第2列。

第二步可以走到第1行第1列,第三步走到第2行第1列,后面经过第3行第1列、第3行第2列到达第3行第3列。
评测用例规模与约定

前30%的评测用例满足:0 < n, m ≤ 10,0 ≤ t < 99。
  所有评测用例满足:0 < n, m ≤ 100,0 ≤ t < 9999,1 ≤ r ≤ n,1 ≤ c ≤ m,0 ≤ a ≤ b ≤ 100。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
#include<iostream>
#include<queue>
#include<vector>
#include<set>
#include<cstring>
#include<math.h>
#define INF 1e8
#define test 0

using namespace std;
struct ge{
int x,y;
ge(int xx,int yy):x(xx),y(yy){


}
};
bool vis[100+2][100+2][300];
int dirs[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
int main(){
int n,m,t;
cin>>n>>m>>t;
int x,y,st,ed;

for(int i=0;i<t;i++){
cin>>x>>y>>st>>ed;
// v.push_back(ge(x,y));
for(int k=st;k<=ed;k++)
vis[x][y][k]=1;
}
int step=0;

queue<ge> q;
q.push(ge(1,1));
vis[1][1][0]=true;
int ans=INF;
while(!q.empty()){
int size=q.size();
while(size--){
ge index=q.front();
q.pop();

int x=index.x;
int y=index.y;

if(x==n&&y==m) {
ans=step;
cout<<ans<<endl;
return 0;
}
for(int j=0;j<4;j++){
int newx=x+dirs[j][0];
int newy=y+dirs[j][1];

if(newx<=0||newx>n||newy<=0||newy>m) continue;

if(vis[newx][newy][step+1]) continue;
//!!递推型
vis[newx][newy][step+1]=true;
#if test
cout<<x<<" "<<y<<" "<<newx<<" "<<newy<<endl;
#endif
q.push(ge(newx,newy));
}

}
step++;


}



}

错误代码

不能简单的限制为访问过的格子不能再访问

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
#include<iostream>
#include<queue>
#include<vector>
#include<set>
#include<cstring>
#include<math.h>
#define INF 1e8
#define test 0

using namespace std;
struct ge{
int x,y;
ge(int xx,int yy):x(xx),y(yy){


}
};
struct node{
int x,y,st,ed;
node(int xx,int yy,int ss,int ee):x(xx),y(yy),st(ss),ed(ee){


}
};
vector<node> v;
int dirs[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
int main(){
int n,m,t;
freopen("t1.txt","r",stdin);
cin>>n>>m>>t;
int x,y,st,ed;

for(int i=0;i<t;i++){
cin>>x>>y>>st>>ed;
v.push_back(node(x,y,st,ed));
}
int step=0;

queue<ge> q;
q.push(ge(1,1));
//vis[1][1]=true;
int ans=INF;
while(!q.empty()){
int size=q.size();
while(size--){
ge index=q.front();
q.pop();

int x=index.x;
int y=index.y;

if(x==n&&y==m) {
ans=step;
cout<<ans<<endl;
return 0;
}
for(int j=0;j<4;j++){
int newx=x+dirs[j][0];
int newy=y+dirs[j][1];

if(newx<=0||newx>n||newy<=0||newy>m) continue;
int flag=0;
for(int i=0;i<t;i++){
if(newx==v[i].x&&newy==v[i].y&&step+1>=v[i].st&&step+1<=v[i].ed)
{
flag=1;
}

}
if(flag==1) continue;
#if test
cout<<x<<" "<<y<<" "<<newx<<" "<<newy<<endl;
#endif
q.push(ge(newx,newy));
}

}
step++;


}



}