HDU2017 字符串统计

Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。

Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。

Sample Input

2

asdfasdf123123asdfasdf

asdf111111111asdfasdfasdf

Sample Output

6

9

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include<iostream>
#include <string>
#include <vector>
using namespace std;
int main()
{
char s[100];
int n;
cin>>n;
while(n--){
int cnt=0;
cin>>s;
for(int i=0;s[i]!=0;i++)
if(s[i]>='0'&&s[i]<='9')
cnt++;
cout<<cnt<<endl;
}}
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
    


#include<iostream>
#include <string>
#include <vector>
using namespace std;
int main()
{
char s[100];
int n;
cin>>n;
while(n--){


cin>>s;
char *t=s;
int cnt=0;
while(*t){
if(*t>='0'&&*t<='9')
cnt++;
t++;
}
cout<<cnt<<endl;
}

}