HDU1229 还是A+B【水题】

Problem Description
读入两个小于10000的正整数A和B,计算A+B。需要注意的是:如果A和B的末尾K(不超过8)位数字相同,请直接输出-1。

Input
测试输入包含若干测试用例,每个测试用例占一行,格式为”A B K”,相邻两数字有一个空格间隔。当A和B同时为0时输入结束,相应的结果不要输出。

Output
对每个测试用例输出1行,即A+B的值或者是-1。

Sample Input
1 2 1 11 21 1 108 8 2 36 64 3 0 0 1

Sample Output
3 -1 -1 100

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
#include<iostream>
using namespace std;
int main(){
int k,a,b,c,tmp,d;
while(cin>>a>>b&&a!=0&&b!=0){
cin>>k;
int flag=1;
tmp=a+b;
for(int i=0;i<k;i++){
c=a%10;
d=b%10;
if(c!=d) flag=0;
a/=10;
b/=10;
}
if(flag==1) cout<<-1<<endl;
else cout<<tmp<<endl;
}
}
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38


/* HDU1229 还是A+B */

#include <iostream>
#include <cstdio>

using namespace std;

int power(int a, int n)
{
int res = 1L;
while(n) {
if(n & 1L)
res *= a;
a *= a;
n >>= 1;
}
return res;
}

int main()
{
int a, b, k, temp;

while(scanf("%d%d%d", &a, &b, &k) != EOF) {
if(a == 0 && b == 0)
break;

temp = power(10, k);
if(k > 0 && a % temp == b % temp)
printf("-1\n");
else
printf("%d\n", a + b);
}

return 0;
}