问题描述
已知一个有理数类Zrf_Ratio,实现如下的操作符重载形式:
friend std::ostream& operator<<(std::ostream&, const zrf_Ratio&);//输出最简分数
friend std::istream& operator>>(std::istream&, zrf_Ratio&);
friend bool operator==(const zrf_Ratio&, const zrf_Ratio&);
friend bool operator<(const zrf_Ratio&, const zrf_Ratio&);
测试
测试时主程序会输入四个整数a, b, c, d,表示两个分数a/b和c/d。要求输出最简分数以及两个分数相等和大小的比较结果。
样例输入
1 7 26 25
样例输出
zrf is:1/7; ssh is:26/25
(zrf==ssh) is:0; (zrf<ssh) is:1
填空题 看清题目 已知一个有理数类
补充代码1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21ostream& operator<<(std::ostream& os, const zrf_Ratio& p)//输出最简分数
{
os<<p.num<<"/"<<p.den;
return os;
}
istream& operator>>(std::istream& is, zrf_Ratio& p){
is>>p.num>>p.den;
return is;
}
bool operator==(const zrf_Ratio& p, const zrf_Ratio& q){
if(p.num*(1.0)/p.den==q.num*(1.0)/q.den) return true;
return false;
}
bool operator<(const zrf_Ratio& p, const zrf_Ratio& q){
return p.num*(1.0)/p.den<q.num*(1.0)/q.den;
}
完整程序1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108#include <iostream>
#include <cassert>
using namespace std;
class zrf_Ratio
{
friend std::ostream& operator<<(std::ostream&, const zrf_Ratio&);
friend std::istream& operator>>(std::istream&, zrf_Ratio&);
friend bool operator==(const zrf_Ratio&, const zrf_Ratio&);
friend bool operator<(const zrf_Ratio&, const zrf_Ratio&);
public:
zrf_Ratio(int=0,int=1);
zrf_Ratio(const zrf_Ratio&);
private:
int num;
int den;
void reduce();//化为最简分数
};
//补充完整构造函数
ostream& operator<<(std::ostream& os, const zrf_Ratio& p)//输出最简分数
{
// cout<<p
// int t=zrf_Gcd(p.num,p.den);
os<<p.num<<"/"<<p.den;
return os;
}
istream& operator>>(std::istream& is, zrf_Ratio& p){
is>>p.num>>p.den;
return is;
}
bool operator==(const zrf_Ratio& p, const zrf_Ratio& q){
if(p.num*(1.0)/p.den==q.num*(1.0)/q.den) return true;
return false;
}
bool operator<(const zrf_Ratio& p, const zrf_Ratio& q){
return p.num*(1.0)/p.den<q.num*(1.0)/q.den;
}
//公有成员函数:
zrf_Ratio::zrf_Ratio(int num, int den) : num(num), den(den)
{
reduce();
}
zrf_Ratio::zrf_Ratio(const zrf_Ratio& r) : num(r.num), den(r.den)
{
}
//私有成员函数:
void swap(int &m, int &n)
{
int t;
t=m;
m=n;
n=t;
}
int zrf_Gcd(int m, int n)
{
if (m<n)
swap(m,n);
assert(n>=0);
while (n>0)
{
int r=m%n;
m = n;
n = r;
}
return m;
}
void zrf_Ratio::reduce()
{
if (num == 0 || den == 0)
{
num = 0;
den = 1;
return;
}
if (den < 0)
{
den *= -1;
num *= -1;
}
if (num == 1)
return;
int sgn = (num<0?-1:1);
int g = zrf_Gcd(sgn*num,den);
num /= g;
den /= g;
}
int main()
{
int a = 0, b = 0, c = 0, d = 0;
cin >> a >> b >> c >> d;
zrf_Ratio zrf(a, b),ssh(c, d);
std::cout<<"zrf is:"<<zrf<<"; ssh is:"<<ssh<<'\n' ;
std::cout<<"(zrf==ssh) is:"<<(zrf==ssh)<<"; (zrf<ssh) is:"<<(zrf<ssh) <<endl;
return 0;
}