A1082 Read Number in Chinese

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output Fu first if it is negative. For example, -123456789 is read as Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu. Note: zero (ling) must be handled correctly according to the Chinese tradition. For example, 100800 is yi Shi Wan ling ba Bai.

Input Specification:
Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:
For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:

-123456789

Sample Output 1:

Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:

100800

Sample Output 2:

yi Shi Wan ling ba Bai

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include<iostream>
using namespace std;
char name[10][5]={"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
string wei[6]={"Shi","Bai","Qian","Wan","Yi"};

int main(){
string s;
cin>>s;

int len=s.length();
int left=0,right=len-1;
if(s[0]=='-') {
cout<<"Fu";
left++;
}
while(left+4<=right){
right-=4;
}
while(left<len){
int flag=0;
bool isP=false;
while(left<=right){
if(s[left]=='0'&&left>0) flag=1;
else{
if(flag==1) {
cout<<" ling";
flag=0;//!!
}
isP=true;
if(left>0) cout<<" ";
cout<<name[s[left]-'0'];
if(right-left>=1) cout<<" "<<wei[right-left-1];
}
left++;
}
if(isP==true&&right!=len-1){//不是个位 ,万、亿位
int tmp=len-1-right;

cout<<" "<<wei[2+tmp/4] ;
}

right+=4;

}

}