A1040 Longest Symmetric String

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:
For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11

dp[i][j]表示从i到j的子串是否为回文串
注意是枚举子串的长度和起始位置
如果枚举两个端点 就无后效性

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
#include<iostream>
#include<cstring>
#define MAX 1001
using namespace std;
int dp[MAX][MAX];
int main(){
string s;
// cin>>s;
getline(cin,s);
memset(dp,0,sizeof(dp));
int len=s.length();
int ans=1;
for(int i=0;i<len;i++){
dp[i][i]=1;
if(i<len-1){
if(s[i]==s[i+1]) {
dp[i][i+1]=1;
ans=2;
}
}
}
for(int l=3;l<=len;l++){
for(int i=0;i<len-l+1;i++){
int j=i+l-1;
if(s[i]==s[j]&&dp[i+1][j-1]==1){
dp[i][j]=1;
ans=l;
}
else dp[i][j]=0;
}
}
cout<<ans<<endl;
}