A1068. Find More Coins

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10
​4
​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10
​4
​​ , the total number of coins) and M (≤10
​2
​​ , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the face values V
​1
​​ ≤V
​2
​​ ≤⋯≤V
​k
​​ such that V
​1
​​ +V
​2
​​ +⋯+V
​k
​​ =M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

1
2
3
4
5
6
7
8
9
10
Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:
No Solution

题目大意:用n个硬币买价值为m的东西,输出使用方案,使得正好几个硬币加起来价值为m。从小到大排列,输出最小的那个排列方案
分析:
此题中价值c[i]和w[i]是等价的
dp[i][j]表示前i(0<=i<n)项物品刚好装进容量为j(0<=j<m)的背包所能获得的最大价值

choice[i][j]表明进行状态转移时选取的哪个策略

01背包问题,因为要输出从小到大的排列,可以先把硬币面额从大到小排列,然后用bool类型的choice[i][j]是否选取,如果选取了就令choice为true;然后进行01背包问题求解,如果最后求解的结果不是恰好等于所需要的价值的,就输出No Soultion,否则从choice[i][j]判断选取的情况,i从n到1表示从后往前看第i个物品的选取情况,j从m到0表示从容量m到0是否选取(j = j – w[i]),把选取情况压入arr向量中,最后输出arr元素

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include<iostream>
#include<vector>
#include<algorithm>
#define MAX 10001
using namespace std;
int n,m;
int w[MAX],dp[110],choice[MAX][110];
int cmp(int a,int b){
return a>b;
}
int main(){
cin>>n>>m;
for(int i=0;i<n;i++)
cin>>w[i];
sort(w,w+n,cmp);
for(int i=0;i<n;i++){
for(int v=m;v>=w[i];v--){
if(dp[v]<=dp[v-w[i]]+w[i]){
dp[v]=dp[v-w[i]]+w[i];
choice[i][v]=1;
}
else choice[i][v]=0;
}
}
vector<int> arr;
if(dp[m]!=m) {
cout<<"No Solution"<<endl;
}

else{
int v=m,k=n-1;
while(k>=0){
if(choice[k][v]==1){
arr.push_back(w[k]);
v-=w[k];
}
k--;
}

}
for(int j=0;j<arr.size();j++){
cout<<arr[j];
if(j!=arr.size()-1) cout<<" ";
}

}

dfs+剪枝

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
#define MAX 10001
int n,m,w[MAX];
vector<int> ans;
bool flag=false;
void dfs(int index,int sum){
//剪枝
if(flag||sum>m) return;
if(sum==m){
flag=true;
for(vector<int>::iterator it=ans.begin();it!=ans.end();it++){
cout<<*it;
if(it!=ans.end()-1)cout<<" ";
}

return;
}
for(int j=index;j<n;j++){
ans.push_back(w[j]);
dfs(j+1,sum+w[j]);
ans.pop_back();
}


}
int main(){
//freopen("31.txt","r",stdin);
cin>>n>>m;
int sum=0;
for(int i=0;i<n;i++){
cin>>w[i];
sum+=w[i];
}
if(sum<m){
cout<<"No Solution"<<endl;
return 0;
}
sort(w,w+n);
dfs(0,0);
if(!flag) {
cout<<"No Solution"<<endl;
}

}

参考链接
https://blog.csdn.net/feng_zhiyu/article/details/82259498
https://www.liuchuo.net/archives/2323
https://blog.csdn.net/xyt8023y/article/details/47255241