A1029 Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10
​5
​​ ) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:
For each test case you should output the median of the two given sequences in a line.

1
2
3
4
5
Sample Input:
4 11 12 13 14
5 9 10 15 16 17
Sample Output:
13

最后一个case容易内存超限 主要方法是第二个数组 边存边比较
知道中位数的位置

法一

一个队列存好后,把第二个队列边读,边和第一个队列比较,选择出队。这样可以不用一次存完第二个队列,解决超内存的问题。

思路:
第一、二个序列分别有n, m个元素,所以需要从队头剔除(n + m – 1) / 2个元素,最后答案就是两个队头的最小值。对于最终答案在第一第二个队列中的情况要分开处理。若答案在第二个队列中,在输入数据时就可以提前得出答案并退出,若答案在第一个队列中,要二次出队才能找到答案。
注意:
在所有元素入队列完毕后,把INT_MAX入队列,一是这样队列永不为空,方便处理。
修改:
1.题目说数据不超过long int, long int占4还是8个字节是要看具体情况的。
2.根据测试代码1,测得所有数据不超过int
3.根据测试代码2,测得PAT中 long int占8个字节

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include <iostream>
#include <climits>
#include <queue>
using namespace std;
int main() {
queue<int> a, b;
int n, m, num, cnt = 0;
scanf("%d", &n);
for(int i = 0; i < n; i++) {
scanf("%d", &num);
a.push(num);
}
a.push(INT_MAX);
scanf("%d", &m);
for(int i = 0; i < m; i++) {
scanf("%d", &num);
b.push(num);
if(cnt == (n + m - 1) / 2) {
printf("%d", min(a.front(), b.front()));
return 0;
}
if(a.front() < b.front())
a.pop();
else
b.pop();
cnt++;
}
b.push(INT_MAX);
for(; cnt < (n + m - 1) / 2; cnt++) {
if(a.front() < b.front())
a.pop();
else
b.pop();
}
printf("%d", min(a.front(), b.front()));
return 0;
}

法二

开一个数组,在线处理第二个数组。 第一二个数组(下标从1开始)分别有n,m个元素,中间数在(n + m + 1) / 2的位置。所以只要从小到大数到(n + m + 1) / 2的位置就行了~ count计总个数 ,给第一个数组设置指针i,每次从第二个数组中读入temp,检查第一个数组中前几个数是不是比temp小,小就count+1并判断是否到数了中间数,到了就输出。 如果数完比temp小的数还没到中间数,count+1,检查temp是不是中间数,是就输出。循环上述过程。如果第二个数组读取完了,还没数到中间数,说明中间数在剩下的第一个数组中,就在剩下的数组中数到中间数位置即可

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include<iostream>
#define MAXN 1000000
#define INF 0x3f3f3f
using namespace std;

int a[MAXN],b[MAXN],num[2*MAXN];
int main(){

int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
a[n]=INF;
// for(int i=0;i<=n;i++)
// cout<<a[i]<<endl;
int m;
cin>>m;
int tmp;
int i=0,cnt=0;
int mid=(n+m+1)/2;
for(int j=0;j<m;j++){
cin>>tmp;
while(a[i]<tmp){
cnt++;
if(cnt==mid) cout<<a[i];
i++;
}
cnt++;
if(cnt==mid) cout<<tmp;
}
while(i<n){
cnt++;
if (cnt == mid) cout << a[i];
i++;
}

}

段错误 内存超限

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
#include<iostream>
#define MAXN 200010
#define INF 0x7fffffff
using namespace std;

int a[MAXN],b[MAXN];
int main(){

int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
a[n]=INF;
int m;
scanf("%d",&m);
for(int i=0;i<m;i++)
scanf("%d",&b[i]);
b[m]=INF;

int i=0,j=0;
int sum=(n+m-1)/2;
int cnt=0;
while(cnt<sum){
if(a[i]<=b[j]){
i++;
}
else j++;
cnt++;
}
if(a[i]<b[j]) printf("%d\n",a[i]);
else printf("%d\n",b[j]);
}

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include<iostream>
#define MAXN 20002
using namespace std;

long a[MAXN],b[MAXN],num[40002];
int main(){

int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);

int m;
scanf("%d",&m);
for(int i=0;i<m;i++)
scanf("%d",&b[i]);
int i=0,j=0,k=0;
while(i<n&&j<m){
if(a[i]<=b[j]){
num[k++]=a[i++];
}
else num[k++]=b[j++];
}
while(i<n) num[k++]=a[i++];
while(j<m) num[k++]=b[j++];

cout<<num[(n+m-1)/2];

}

参考链接
https://www.xieminjie.cn/?p=257
https://blog.csdn.net/liuchuo/article/details/52221378