蓝桥杯 日期问题

标题:日期问题

小明正在整理一批历史文献。这些历史文献中出现了很多日期。小明知道这些日期都在1960年1月1日至2059年12月31日。令小明头疼的是,这些日期采用的格式非常不统一,有采用年/月/日的,有采用月/日/年的,还有采用日/月/年的。更加麻烦的是,年份也都省略了前两位,使得文献上的一个日期,存在很多可能的日期与其对应。

比如02/03/04,可能是2002年03月04日、2004年02月03日或2004年03月02日。

给出一个文献上的日期,你能帮助小明判断有哪些可能的日期对其对应吗?

输入

一个日期,格式是”AA/BB/CC”。 (0 <= A, B, C <= 9)

输出

输出若干个不相同的日期,每个日期一行,格式是”yyyy-MM-dd”。多个日期按从早到晚排列。

样例输入

02/03/04

样例输出

2002-03-04
2004-02-03
2004-03-02

资源约定:
峰值内存消耗(含虚拟机) < 256M
CPU消耗 < 1000ms

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
#include<bits/stdc++.h>
#include<iostream>
using namespace std;
//读懂题 a,b,c 日月年 月日年 年月日
int month[12]={31,28,31,30,31,30,31,31,30,31,30,31};
struct date{
int y,m,d;
date(int yy,int mm,int dd):y(yy),m(mm),d(dd){
}
date(){
}
void print()const{
printf("%d-%02d-%02d\n",y,m,d);
}
bool operator <(date other) const{

if(y==other.y){
if(m==other.m) return d<other.d;
return m<other.m;
}
return y<other.y;
}
};
set<date> dict;
bool valid(date datte){
if(datte.y<1960||datte.y>2059) return false;
if(datte.m<=0||datte.m>12) return false;
if(datte.y%400==0||(datte.y%4==0&&datte.y%100!=0)){
month[1]=29;
}
if(datte.d<=0&&datte.d>month[datte.m-1])
return false;
return true;

}
void insert(int a,int b,int c ){
date obj(a,b,c);
if(valid(obj)) dict.insert(obj);//插入到set 结构体需要有operator <比较 才知道怎么插入
}

int main(){
int a,b,c;
scanf("%d/%d/%d",a,b,c);
insert(1900+a,b,c);
insert(2000+a,b,c);
insert(1900+c,a,b);
insert(2000+c,a,b);
insert(1900+c,b,a);
insert(2000+c,b,a);
for(set<date>::iterator it=dict.begin();it!=dict.end();it++)
{
// printf("%d-%02d-%02d\n",it) 要在结构体内定义 才能遍历
it->print();
}
}