A1020 Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

1
2
3
4
5
6
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
#include<bits/stdc++.h> 
#define MAX 40
using namespace std;
typedef long long ll;
int in[MAX],post[MAX];
int n,k,p;
struct node
{
int v;
node *left;
node *right;

};
//返回构建出的二叉树根节点地址
node* create(int postl,int postr,int inl,int inr){
if(postl>postr)
return NULL;
int i;
for(i=inl;i<=inr;i++){
if(in[i]==post[postr]) {
break;
}
}
node *t=new node();//!
t->v=post[postr];
int numl=i-inl; //!
t->left=create(postl,postl+numl-1,inl,i-1);//!
t->right=create(postl+numl,postr-1,i+1,inr);//!
return t;
}
int num=0;
void bfs(node *root){
queue<node*> que;
que.push(root);
while(!que.empty()){
node *t=que.front();
que.pop();
cout<<t->v;
num++;
if(num<n) cout<<" ";
if(t->left!=NULL) que.push(t->left);
if(t->right!=NULL) que.push(t->right);
}

}
int main(){
cin>>n;
for(int i=0;i<=n-1;i++)
cin>>post[i];
for(int i=0;i<=n-1;i++)
cin>>in[i];

node *root=create(0,n-1,0,n-1);
bfs(root);


}