A1099 Build A Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include<bits/stdc++.h>
using namespace std;
int n;
#define MAX 110
int in[MAX],num[MAX];
struct node{
int v;
int l,r;
};
node tree[MAX];
bool cmp(int m,int n){
return m<n;
}
int sum=0;
void inorder(int t){
if(t==-1) return;
inorder(tree[t].l);
tree[t].v=in[sum++];
inorder(tree[t].r);
}
void bfs(int r){
sum=0;
queue<int> que;
que.push(r);
while(!que.empty()){
int tt=que.front();
cout<<tree[tt].v;
sum++;
if(sum<n) cout<<" ";
que.pop();
if(tree[tt].l!=-1) que.push(tree[tt].l);
if(tree[tt].r!=-1) que.push(tree[tt].r);

}
}
int main(){
cin>>n;
for(int i=0;i<n;i++){
cin>>tree[i].l>>tree[i].r;
}
for(int j=0;j<n;j++)
cin>>in[j];
sort(in,in+n,cmp);
inorder(0);
bfs(0);
}