A1085 Perfect Sequence

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10
​5
​​ ) is the number of integers in the sequence, and p (≤10
​9
​​ ) is the parameter. In the second line there are N positive integers, each is no greater than 10 9

Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
#include<bits/stdc++.h>
using namespace std;
int n;
#define MAX 100010
int a[MAX];
int main(){
int n,p;
cin>>n>>p;
for(int i=0;i<n;i++){
cin>>a[i];
}
sort(a,a+n);//忘记sort
int ans=1;
for(int k=0;k<n;k++){

int t=upper_bound(a+k+1,a+n,(long long)a[k]*p)-a;
ans=max(ans,t-k);
}
cout<<ans<<endl;
}