A1051 Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

1
2
3
4
5
6
7
8
9
10
11
12
13
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO

注意 必须判断是否栈空
在每个出栈序列前一定要清空栈,否则上个出栈序列没清空 会影响下次出栈序列过程

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include<bits/stdc++.h>
using namespace std;
#define MAX 1010
int arr[MAX];
stack<int> s;
int main(){
int M,N,K;
cin>>M>>N>>K;

for(int i=0;i<K;i++){
while(!s.empty()){
s.pop();
}
for(int j=1;j<=N;j++ ){
cin>>arr[j];
// if(arr[j])
}
int cur=1;
bool f=true;// 3 2 1 5 6 4
for(int k=1;k<=N;k++){
s.push(k);
if(s.size()>M) {
f=false;break;
}
while(!s.empty()&&s.top()==arr[cur]){
s.pop();
cur++;
}



}

if(f==true&&s.empty()==true) cout<<"YES"<<endl;
else{
cout<<"NO"<<endl;
}



}



return 0;
}